Question

Ubuntu server denying my password when I try to log in. Tried resetting root password, restoring from a snapshot. Neither worked.

Posted December 15, 2016 2.2k views
Linux BasicsUbuntu 16.04

I tried using the “reset root password” option from the access panel of my droplet. I was emailed a new password. When I tried to use it to log in as root from the web console, I got the same “login incorrect” message. I tried restoring the droplet to a snapshot that was taken a week ago (everything was working fine earlier today so I figured this would help). However the problem persists. If I can’t find a solution, I’ll have no choice but to start a new droplet. Any help would be much appreciated. Thanks.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Make sure that you type password manually if you are using Web Console. You can’t copy/paste in Console window.
Also make sure you are using right keyboard layout, also if you are using numeric part of keyboard check is it working in Console (and is Numlock On).

Once you type root and after that your password, you’ll be logged in, but you’ll have to change password.
First type in old (current), then 2 times new one.

If you can’t make it working. Contact Support and ask them to mount Recovery ISO to your Droplet. From there, you can try changing password or backing up your data.

  • That did it, thanks! Turns out my password manager was behaving strangely and adding some characters to the beginning and end of my passwords when copying them to the clipboard. That was why I couldn’t get in initially.

Submit an Answer