Unable to install pyhton 3.7 version on ubuntu 16.04 error Couldn't find any package by regex 'python3.7

September 11, 2019 210 views
Python

I have installed python 3 through this command

sudo apt-get install python3

and when checked the version using
python3 -V

it was python 3.5.2

I wanted to install python version 3.7, and when tried the following

sudo apt-get install python3.7

I got he following error

E: Unable to locate package python3.7
E: Couldn’t find any package by glob ‘python3.7’
E: Couldn’t find any package by regex 'python3.7’

any help will be highly appreciated,
many thanks,
Hayat

1 Answer
bobbyiliev MOD September 11, 2019
Accepted Answer

Hello,

Have you tried running python3.7 --version instead of only python3?

If this still does not work what I would suggest is following these steps here:

  • Run a quick update and install the following package:
apt update
sudo apt install software-properties-common
  • Add the following to your source list:
sudo add-apt-repository ppa:deadsnakes/ppa

Note: In case that you get prompted just press Enter to continue

  • After that install Python 3.7 with the command that you’ve specified in your question:
sudo apt install python3.7

Then again test this with:

python3.7 --version

Hope that this helps!
Regards,
Bobby

  • Many thanks for your quick response

    I tried python3.7 –version, but it didn’t work -> no python3.7 found

    I did all what you suggested; installed packages and updated the repository, and when tried to run

    sudo apt install python3.7
    ended up with the same result before

    E: Unable to locate package python3.7
    E: Couldn’t find any package by glob ‘python3.7’
    E: Couldn’t find any package by regex 'python3.7’

    I have instaled pyhton 3.5, I need to update to pyhton3.7
    but I got above error each time I tried to install

    your help is apprecaited,
    Thanks,
    Hayat

    • Ops! I forgot to execute –> sudo apt-get update
      after I updated the repository

      I ran it and then
      sudo apt install python3.7

      and it works nicely, now I have Python 3.7.4 installed,

      many many thanks,
      Best regards,
      Hayat

Have another answer? Share your knowledge.