Unable to set HTTPS using LetsEncrypt in Nginx server

February 28, 2018 2.4k views
Nginx Let's Encrypt Ubuntu 16.04

I followed the following tutorial to set https for my website:

But, I got stuck at this place - Step 6 — Securing your Application with TLS

There are no ssl-*.conf in my snippets folder to match the lines in the above conf file for TLS. I did not see any other errors up to this point. I can view my site with Http, but not HTTPS. Please advise.

include snippets/ssl-example.com.conf;
include snippets/ssl-params.conf;

The following command:

$ sudo nginx -t


nginx: [emerg] open() "/etc/nginx/snippets/ssl-example.com.conf" failed (2: No such file or directory) in /etc/nginx/sites-enabled/example.com:13

Yes, those files aren't there. So, I guess the tutorial skipped the step that generated those files.

The following command:

$ ls /etc/nginx/snippets



Clearly the ssl-*.conf files are missing.

Please help.

Thanks in advance.

1 comment
1 Answer
fierysoft May 14, 2018
Accepted Answer

After playing around some time with Google, I found the resources I needed to solve this issue. I have outlined the steps I did here: Unable To Set HTTPS Using LetsEncrypt

Have another answer? Share your knowledge.