Hi there,

I am trying to upload assets through the getSignedUrl method that the aws-sdk provides, a NodeJS backend with Axios where the upload happens from a VueJS 2 frontend. Now whatever combination i try, or the file is able to upload but always sets it to private and the wrong Content-Type, or i get 403 permission errors.

What i want to do is that the upload has an ACL that is public-read and the correct Content-Type.

The following is the code that i use:

To get a signed Url

const s3 = new AWS.S3({
    accessKeyId: keys.spacesAccessKeyId,
    secretAccessKey: keys.spacesSecretAccessKey,
    signatureVersion: 'v4',
    endpoint: 'https://fra1.digitaloceanspaces.com',
    region: 'fra1'

app.get('/api/upload/image', (req, res) => {
        const type = req.query.type;

        s3.getSignedUrl('putObject', {
            Bucket: 'vondel',
            ContentType: type,
            ACL: 'public-read',
            Key: 'random-key'
        }, (error, url) => {
            if (error) {
            console.log('KEY:', key);
            console.log('URL:', url);
            res.send({ key, url });

This provides a signed url that looks like:


Then for actually uploading the file i use the following:

await UploadService.uploadImage(uploadConfig.data.url, file, {
          'x-amz-acl': 'public-read',
          'Content-Type': file.type

With the service looking like:

  async uploadImage (url, file, headers) {
    await axios.put(url, file, headers.headers);
1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

1 answer

What i had to do to fix this issue, was going to the Settings page of my Spaces instance and add to the CORS section the following allowed Headers (i had previously set the Origin to be a wildcard as i am working from localhost, eventually you want to restrict this to a domain).

But add the allowed headers ‘Content-Type’ and 'x-amz-acl’ to properly set the content type and the ACL.

This way i was able to upload an image to my DigitalOcean spaces with public permission and the right content type.

Submit an Answer