When I login to plesk via SSH link it shows unsecured on browser. Please help.

November 2, 2019 154 views
Control Panels Security WordPress

I’m logging into an IP address but it shows unsecured. How do I secure it via an SSL? Note that my websites inside wordpress are SSL secured. Just need help with plesk being unsecure.

2 Answers

Hello,

It happens usually when the SSL certificate assigned to Plesk is expired or self-signed.

I would recommend following the steps from the official Plesk documentation here on how to fix that problem:

https://support.plesk.com/hc/en-us/articles/213954265

Hope that this helps!
Regards,
Bobby

So I tried following the steps for Let’s Encrypt part. I’m unsure what must enter in the domain name section. I tried entering the IP address but that’s not allowed.

Tried entering droplets name.local and it says Error: Could not issue a Let’s Encrypt SSL/TLS certificate for ‘Droplet name.local’

Perhaps this domain is at risk group and is blacklisted on the Let’s Encrypt side.

So no IP addresses and no droplet name. What exactly should I enter in there?

  • Hi @notslow ,

    So if you would like to use the HTTPS protocol (secured HTTP), you will need a certificate. Like @bobbyiliev mentioned, if you do not get a valid cert you will get a warning. You can still continue tho, by ignoring the warning and clicking “Continue” in your browser.

    If you like to create a free Let’s Encrypt SSL certificate you need a domain to be used. Certificates are bound to domains like example.com and can not be binded to an IP address. That’s why your setup above isn’t working.

    Hope this helped you. If not, feel free to request some more help

Have another answer? Share your knowledge.