Question

Why am I suddenly unable to ping or curl a floating IP server from itself?

I have configured a floating IP to point at my server.

When I do: ping <my-floating-ip-address>

It works fine from my computer and from other servers. But when I run the same command from the server itself (i.e. the server currently pointed to by the floating IP), it produces no results.

Uptil yesterday I was able to do a curl from my server to itself via the floating IP. Today I can’t. I haven’t changed any configuration on my side.

Has something changed in the way floating IP addresses work?

I’ll include my firewall settings for completeness, but I haven’t changed them recently and, as I say, it used to work.

Chain INPUT (policy DROP)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere
ACCEPT     all  --  anywhere             anywhere             state RELATED,ESTABLISHED
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:http state NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:https state NEW
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:ssh state NEW
ACCEPT     icmp --  anywhere             anywhere             limit: avg 1/sec burst 5 icmp echo-request

Chain FORWARD (policy DROP)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Digital Ocean support asked me to try to unassigning and reassigning my floating IP. It worked. (But doesn’t explain why it happened in the first place and whether it will happen again. I hope they will look into it.)

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Thanks @david615230 - unassigning and reassigning did the trick for me too.

But having this happen out of the blue today on my production site with no explanation is making me really afraid of using floating ips from DigitalOcean…