WordPress and GoDaddy problem Domain and Url

February 10, 2017 428 views
WordPress Apache CMS DigitalOcean

Hi everyone. I installed WordPress in Ubuntu, and I have a domain i want to use with the WordPress Droplet, I put the DNS configuration (AAA, A, CNAME) like the config tutorial everything works fine, in GoDaddy I point to my DO servers, everything is fine.. But, when I go to the domain url it shows the page but changes my domain URL to the droplet IP URL. Like redirects the DOMAIN to the IP and the URL changes from mydomain.com to the 192.xxx.xxx. IP droplet.

I see many post of this problem here, so, i change the URL Settings in WordPress Dashboard (only the homepage URL) to mydomain.com, it loads perfect but fonts icons are not loading correctly and when I try to go the WordPress admin panel, I can't, so I inspect with JS the url and seems like is redirecting to the mydomain.com URL and not the droplet (where are all the files) and loops, so I change the URL in the JS inspector and put the Droplet IP. In the inspector, doing this i can enter, and I was be able to edit the URL Settings in WordPress Dashboard and put the older (IP Droplet Adress) instead the domain..

My question is.. How I can have this working? I have to put mydomain.com in both of Settings URL of WordPress Dashboard and will work fine? Or the pages will crash? This is a Apache problem config? Please.. I will appreciate any help, I have days in this problem..

5 Answers
jtittle February 10, 2017
Accepted Answer

@infocreditprotech

When you first install WordPress, it uses whatever hostname or IP is used to access the installer. So if you used an IP to install WordPress, then the IP is used as your sites URL.

You can modify ./wp-config.php and within it, add:

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

... save the file, upload it, and then refresh the page and that should set your URL to your domain without any further changes needed. Simply change example.com to your actual domain.

@jtittle Thanks for your reply. I have done that only with the home URL, You say that I have to do this with both URL Settings? This will not crash the site, right? I mean.. If I modify the Site URL that will not affect in which url WordPress will search the directory of the files in the domain? Or will this look for it anyway in the IP of the droplet?

  • @infocreditprotech

    The purpose of the above settings is to remove the need for the IP and set all URL's to that of your domain so that only your domain is used. You'll need to set them both, or set them both from ./wp-admin -- the options inside the control panel do the same thing, this is just one way of doing it when you're moving from an IP to a domain.

@jtittle Hi, sorry for the late reply, I did what you told me but the pages is not showing and throws an 500 error (Page can't be load) . I change the variables with my domain URL but throws that error. I delete them and the page loads correctly but.. redirecting to the IP.
What you think is the problem?

@jtittle , Sorry! It works! Thank you very much!!! Now I can see my domain and login to WordPress without problems. But.. the icons fonts for the theme loads by the IP adress and throws an JavaScript problem, this not show the font icons. What you think is the problem here? Is something in the theme url or?

@infocreditprotech

If this icon set is specific to the theme, you may need to deactivate it and then reactivate it and see if that works. By default, if a theme is coded properly, it should be able to use whatever WordPress has set as the URL, whether it's an IP or domain name.

The exception to this, of course, would be if you hard-coded the IP in to your stylesheet, in which case you'd need to modify your stylesheet and update the URL(s).

Have another answer? Share your knowledge.