Question

Adding new IP address in mongod.conf in bindIp doesn't work

Posted September 17, 2020 298 views
MongoDBUbuntuUbuntu 20.04

Ubuntu: 20.04
MongoDB: 4.4.1

I was following this tutorial (https://www.digitalocean.com/community/tutorials/how-to-configure-remote-access-for-mongodb-on-ubuntu-20-04) and I have a problem with adding new IP address in the bindIp property.

I tried same thing as it is in the tutorial but it doesn’t work:

net:
  port: 27017
  bindIp: 127.0.0.1,there_is_my_ip

I was looking for the answer and trying other options like [127.0.0.1,there_is_my_ip] or "127.0.0.1,there_is_my_ip" but none of these work for me.

After adding new IP with any of these options my MongoDB server fails to start.

What should I do?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @PtakWarsawExpo,

I’ve just tested this on a fresh new Ubuntu 20 Droplet with MongoDB 4.4 and it seems to be working as expected. My configuration is:

# network interfaces
net:
  port: 27017
  bindIp: 127.0.0.1,droplet_ip_address

What is the exact error that you get when you try to start MongoDB?

Also did you follow the prerequisites and install MongoDB 4.4:

https://www.digitalocean.com/community/tutorials/how-to-install-mongodb-on-ubuntu-20-04

If you used the default MongoDB from the apt repository, it would mean that you have MongoDB 3.x installed.

To verify that you can run:

  • mongod -v | grep -i version

Hope that this helps and let me know how it goes.
Regards,
Bobby

by Mark Drake
MongoDB is an open-source document database used commonly in modern web applications. It is classified as a NoSQL database because it does not rely on a traditional table-based relational database structure. Instead, it uses JSON-like documents with dynamic schemas. In this tutorial you'll install MongoDB on an Ubuntu 20.04 server, test it, and learn how to manage it as a systemd service.
  • Hi, thanks for the answer.
    And yes, I have mongo 4.4 and I followed instructions from the tutorial. Maybe the problem is with that I’m providing IP address of my local computer? When I tried to do 127.0.0.1,0.0.0.0 and restarted mongo and then started it again, it still fails too. Error message on starting mongodb: Active: failed and ExecStart=/usr/bin/mongod --config /etc/mongod.conf (code=exited, status=48)

Submit an Answer