Question

Adding new IP address in mongod.conf in bindIp doesn't work

Ubuntu: 20.04 MongoDB: 4.4.1

I was following this tutorial (https://www.digitalocean.com/community/tutorials/how-to-configure-remote-access-for-mongodb-on-ubuntu-20-04) and I have a problem with adding new IP address in the bindIp property.

I tried same thing as it is in the tutorial but it doesn’t work:

net:
  port: 27017
  bindIp: 127.0.0.1,there_is_my_ip

I was looking for the answer and trying other options like [127.0.0.1,there_is_my_ip] or "127.0.0.1,there_is_my_ip" but none of these work for me.

After adding new IP with any of these options my MongoDB server fails to start.

What should I do?

Subscribe
Share

Ok, so I struggled with this for way too long.

My problem was I thought I was supposed to “bindIp” of the connecting device. Nope, I misunderstood, when I instead bindIp of the mongo-droplet public IP everything worked just fine.

Also, do not believe other statements on internet about formatting the IP list as a string using “” or a array using []. This tutorial is correct, just comma-separated is the way to go if your’e using mongo 4.4! (haven’t tested with spaces though)

Hopes this saves time for someone :)

Same behavior for me, as experienced by @PtakWarsawExpo. Another relevant detail may be that after adding any ip address to the mongodb.conf file’s net/bindIp parameter, I’m unable to log into mongo at all, even from the same server (127.0.0.1).

so in mongod.conf:

net: port: 27017 bindIp: 127.0.0.1

mongo -u myadminusername -p --authenticationDatabase admin

MongoDB shell version v4.4.2
Enter password:
connecting to: mongodb://127.0.0.1:27017/?authSource=admin&compressors=disabled& gssapiServiceName=mongodb
Implicit session: session { “id” : UUID(“6623b41d-699e-4d0b-b088-940b0528957a”) }
MongoDB server version: 4.4.2

But when the net/bindIp config is changed:

net: port: 27017 bindIp: 127.0.0.1,my.remote.ip.addr

mongo -u myadminusername -p --authenticationDatabase admin

MongoDB shell version v4.4.2 Enter password: connecting to: mongodb://127.0.0.1:27017/?authSource=admin&compressors=disabled& gssapiServiceName=mongodb Error: couldn’t connect to server 127.0.0.1:27017, connection attempt failed: So cketException: Error connecting to 127.0.0.1:27017 :: caused by :: Connection re fused : connect@src/mongo/shell/mongo.js:374:17 @(connect):2:6 exception: connect failed exiting with code 1

After removing the remote ip address from mongodb.conf’s net/bindIp, I can log back in to mongo, on the mongodb server.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there @PtakWarsawExpo,

I’ve just tested this on a fresh new Ubuntu 20 Droplet with MongoDB 4.4 and it seems to be working as expected. My configuration is:

# network interfaces
net:
  port: 27017
  bindIp: 127.0.0.1,droplet_ip_address

What is the exact error that you get when you try to start MongoDB?

Also did you follow the prerequisites and install MongoDB 4.4:

https://www.digitalocean.com/community/tutorials/how-to-install-mongodb-on-ubuntu-20-04

If you used the default MongoDB from the apt repository, it would mean that you have MongoDB 3.x installed.

To verify that you can run:

  1. mongod -v | grep -i version

Hope that this helps and let me know how it goes. Regards, Bobby

This comment has been deleted