Certbot error curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to

I’m doing certbot using snap and PPA, both fails miserably. and some people on internet ask whether you can do a curl manually or not. Then I tried to curl it, and it returns error curl: (35) OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to

Does anyone have the same problem ? FYI I’m using the lowest CPU on droplet


FYI, tried to contact support with 19 hours without reply yet.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Just created a snapshot and build a new droplet with the snapshot. Certbot worked normally. I think it’s because of other droplet (lowest droplet uses shared CPU).

Hi @noviceboy17,

In that regard, to your answer, can you confirm what Droplet are you using? What OS and additionally, did you try to run

apt update

Prior to trying to install certbot by any of the mentioned ways?

I’m not sure it’s related to the CPU and it might be something else.

Anyway, I’m glad to see everything is working accordingly.

Regards, KFSys

This comment has been deleted