Question

DNS / Domain taking too long to respond

For some reason I can connect to my droplet using https://www.quentinmccarthy.co.nz/ and it loads, but all the resources are pointing at https://quentinmccarthy.co.nz/. While normally that’s fine, because both of those URL’s point to the same thing. But for some reason the latter one isn’t working, and it’s breaking the former one. If I try to connect to the latter, firefox tells me it took too long to respond and it just won’t work. I’ve tried updating the DNS records multiple times (both the former and latter point to the IP of the droplet and the TTL is default) but it’s just not working. I need this to work for work, so if I could get some help that’d be great.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hey friend!

I was able to load it fine with or without the www. I believe what occurred is that the root domain A record was either missing or not set correctly, and then once you fixed it your system had already performed a lookup for the A record recently, forcing you to wait for the TTL to run out so your system would check for a new record (commonly referred to as DNS propagation). I would bet that everything is working well from your end now as well.

Jarland

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.