Question

Docker build failes when trying to take snapshot. Runs locally.

Hi!

When trying to deploy my Kotlin api, the Docker build fails right after the gradle build succeeds with the following error message:

│ BUILD SUCCESSFUL in 1m 47s
│ 5 actionable tasks: 5 executed
INFO[0114] Taking snapshot of files...                
error building image: error building stage: failed to take snapshot: Failed to get file info for /root/.kotlin/daemon/kotlin-daemon.2024-07-10T18-30-07.756Z.dbc3a82d10b2eac98ec7254f3cca63bc.17553.run: lstat /root/.kotlin/daemon/kotlin-daemon.2024-07-10T18-30-07.756Z.dbc3a82d10b2eac98ec7254f3cca63bc.17553.run: no such file or directory

It runs locally, so I’m very confused about what is going wrong.

My Docker file looks like this:

FROM amazoncorretto:17.0.11-alpine AS _build
_COPY . /build/src
WORKDIR /build/src
RUN ./gradlew :server:buildFatJar --no-daemon

FROM amazoncorretto:17.0.11-alpine
EXPOSE 8080
RUN mkdir /app
COPY --from=_build_ /build/src/server/build/libs/*.jar /app/vacapp.jar
ENTRYPOINT ["java","-jar","/app/vacapp.jar"]

Submit an answer


This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Added RUN ./gradlew clean on the line before I build the jar and now it works. Still no idea why it failed in the first place, though. 🤷🏼

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel