I bought this domain coshop-nozzha.academy from Namecheap and I move it to Digitalocean DNS

After that I pointed the domain to my droplet (dokku droplet)

Then I accessed my dokku app via domain api.coshop-nozzha.academy and everything was fine (I accessed my app without any error)

For some reason I powered off that droplet and I took snapshot of it then I removed it (droplet)

After that I created droplet from that snapshot, the droplet created successfully but when I tried to access my dokku app via domain I got this error ERR_CONNECTION_REFUSED, I refreshed the page so many times but the error is still

I removed that droplet and I created new droplet from offical dokku image then I configured the dokku app settings but that error is still when I accessed my app via domain ERR_CONNECTION_REFUSED

However when I tried to add my droplet ip 159.203.104.64 to dokku app domains and access the app via droplet ip everything working fine

In Recap: I cannot access my dokku app vi domain

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

I was accessing the app using https however the connection wasn’t secure so I solved this problem by accessing the app using http as the follwing http://api.coshop-nozzha.academy or by secure the app connection using letsencrypt dokku plugin and accessing the app using https as the following https://api.coshop-nozzha.academy

Submit an Answer