Gmail can't verify my server's emails even with SPF and DKIM set up

August 21, 2016 315 views
Email Ubuntu

I feel like I've tried EVERYTHING to get my server's email working. I've been working at it on and off for months. Here's what I've done so far:

I'm running a LAMP stack on Ubuntu 14.04

I'm currently hosting two websites using virtual hosts

I followed this guide to set up Exim

Followed this guide to set up SPF and DKIM for my virtual hosts

Here's what my SPF and DKIM records look like

Used this tool to verify my SPF and DKIM records

Everything looks good, and yet when I send a test email from my server to my Gmail account, it is flagged with the question mark icon and says "Gmail couldn't verify that actually sent this message (and not a spammer)."

Could it be that I've taken so long to get this working that Gmail has flagged my domain as spam??

1 comment
  • Are you setting up your own email server? Or are you just sending mail from a website using php mail?

    Have you set your server up with the same domain name...meaning did you name your server with the domain you are sending from? You can check on your /etc/hostname file on your server.

    A different approach is to set up Postfix to use Gmail SMTP servers and not have to worry about being flagged as spam:

    I just did this on one of my servers. Works great.

1 Answer
jpgklassen August 22, 2016
Accepted Answer

FOUND THE ANSWER - I had named my droplet "windhorse", and it turns out all I had to do was rename it to "" (my domain!) It works now!!

Have another answer? Share your knowledge.