Question

Greenlight fails to configure smtp

I have this seetings in the .env file of greenlight in my bigbluebutton server

ALLOW_MAIL_NOTIFICATIONS=true

SMTP_SERVER=.company.mail SMTP_PORT=587 SMTP_DOMAIN=company.mail SMTP_USERNAME=@company.mail SMTP_PASSWORD=*** SMTP_AUTH=plain SMTP_STARTTLS_AUTO=true

SMTP_OPENSSL_VERIFY_MODE=none

SMTP_SENDER=***@company.mail

SMTP_TEST_RECIPIENT=myemail@of.course

Yes, the email works as SMTP, I use it in another service and it works fine with the correct password and the same settings

But when I run this command

docker run --rm --env-file .env bigbluebutton/greenlight:v2 bundle exec rake conf:check

The output prompts

Checking environment: Passed
Checking Connection: Passed
Checking Secret: Passed
Checking SMTP connection: Failed
Error connecting to SMTP - SSL_connect returned=1 errno=0 state=error: wrong version number

I have no idea of what is wrong with it

Thank you in advance


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Well, a partner told me something that I could read correctly because of the dark blue in the vi comments. The error was that I was using this

SMTP_TLS=true

The comment of the line above is

#   enable SMTPS: SMTP over direct TLS connection; usually port 465

So, my SMTP needed to use STARTTLS port 587 and that line was messing it all. Once commented, it all worked

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Update

I found that some people got this fixed using this code

cd /root/greenlight
docker-compose down
docker pull bigbluebutton/greenlight:v2
docker-compose up -d

But that’s not my case, everything us updated and the message prompts the same error

Well, somehow, I can’t edit my own question, and I see that the characters that I used to hide information broke the style, I paste it again but in a more nice way

   ALLOW_MAIL_NOTIFICATIONS=true
   SMTP_SERVER=server.company.address
   SMTP_PORT=587
   SMTP_DOMAIN=company.address
   SMTP_USERNAME=email@company.address
   SMTP_PASSWORD=passwordForThisQuestion
   SMTP_AUTH=plain
   SMTP_STARTTLS_AUTO=true
   SMTP_TLS=true
SMTP_SENDER=email@company.address

SMTP_TEST_RECIPIENT=myemail@of.course