Question

How do you configure MySQL to use block storage on Ubuntu 14.04?

Within /etc/mysql/my.conf, you can easily set datadir=/mnt/your_block/mysql, but there are some deeper issues with apparmor. How do I reconfigure apparmor to acknowledge my new datadir?

I’ve followed directions at [this] (http://askubuntu.com/questions/137424/moving-mysql-datadir) StackOverflow post, but upon completion I get ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/mnt/volume-nyc1-01/mysql/mysqld.sock'

I can’t find mysqld.sock.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Here are the commands I used (see reply above):

mkdir /mnt/disk002/mysql
cp -R /var/lib/mysql /mnt/disk002/mysql/
cp /etc/mysql/my.cnf /root/my.cnf.backup
emacs /etc/mysql/my.cnf

	#datadir		= /var/lib/mysql
	datadir = /mnt/disk002/mysql

chown -R mysql:mysql /mnt/disk002/mysql
mv /var/lib/mysql /var/lib/mysql-old
ln -s /mnt/disk002/mysql /var/lib/mysql 
echo "alias /var/lib/mysql/ -> /mnt/disk002/mysql/," >> /etc/apparmor.d/tunables/alias
sudo /etc/init.d/apparmor reload

start mysql
start: Job failed to start

I’m having no luck on Ubuntu 14.04. I followed the StackOverflow commands above and when I attempt to restart mysql I get:

2016-08-25 15:54:08 1909 [ERROR] Fatal error: Can’t open and lock privilege tables: Table ‘mysql.user’ doesn’t exist

in the error log.

Is there an official DigitalOcean tutorial for 14.04?

Melissa,

That was ineffective. Can DigitalOcean please publish an official tutorial for using MySQL or MariaDB or PostgreSQL w/ the new Block volumes?

Thanks, Sawyer

Apologies. After a closer look at the directions in the StackExchange link you posted and the error you encountered, it looks like the problem may stem from the suggestion to set the socket value: socket=/array2/mysql/mysql.sock,

If you were to put that back to its original setting, the rest of the directions might work as written.

After you’ve undone the stackexchange suggestions, try looking at /etc/apparmor.d/usr.sbin.mysqld and updating the following stanza with the path to your mount:

# Allow data dir access
  /var/lib/mysql/ r,
  /var/lib/mysql/** rwk,

You’ll also need to restart apparmor:

sudo /etc/init.d/apparmor restart

If systemd still squawks about not being able to find /var/lib/mysql when you try to restart mysql you might try creating a symlink between the mount point and the default location as follows (with the appropriate path to your new volume.)

sudo ln -s /volume-nyc1-01/mysql /var/lib/mysql