Question

How to access,upload and download files on droplet

  • Posted on November 15, 2014
  • alaukikkAsked by alaukikk

i have created a droplet, In access droplet i get just option of “Console Access” on my browser. But how do i upload, download or edit files or directories on my ubuntu server?

i tried connecting this through my filezilla using my ip as host and root credentials. i’m unable to connect. i get error as : Connection attempt failed with “ECONNREFUSED - Connection refused by server”.

how do i connect.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

In filezilla login using sftp. Also, enter your correct port number, if you’ve changed it to some other value from 22. After that you’ll be able to upload, download and manage your files.

I found I had to complete the initial server set up tutorial, even though I used a one-click install. Once I was able to login to root with Putty (any ssh tool), it asks to reset the password in the shell. If you haven’t reset the password in the shell, you won’t be able to login with an ftp/sftp client. After I reset the password, I logged in with root and the new password with Filezilla. Unfortunately, it puts you in the user directory, not the top directory. You have to use the dropdown that lets you choose the directory in your ftp client. In Filezilla, it’s on the right and is called “Remote Site:” To find the site files, I had to then browse to /var/www/html

I have the same issue. I cannot make anything related to ssh work. When I tried to install vsFTP, it just hung up the service and I had to reboot/restore the Droplet to make it work. This should be a simple operation and it has taken me 3-4 days to try to resolve this with DO support, to no avail. This is taking wy too long to deal with and no way to speak with someone on the phone. Not good.