Question

How to fix putty error: "Putty fatal error: No supported authentication methods available (server sent: public key)"

Posted October 9, 2019 27.5k views
Initial Server Setup

I am using a new droplet with Ubuntu, and have Windows and Putty on my local machine…For setting up ssh I am following: https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/putty/ and choosing the option to skip over “specify an ssh key…” and use login and password instead, but I get the error: “Putty fatal error: No supported authentication methods available (server sent: public key)”. I do not see any posted solutions which do not involve setting up an ssh key.

1 comment
  • I have the same problem, but I added an SSH key right at the start. Since I don’t have Password authentication activated I don’t think the solutions given make sense for me. I followed the instructions for creating a key and connecting via putty but I keep getting the message “PuTTY Fatal Error - Disconnected: No supported authentication methods available (server sent: publickey)”. I’m probably missing something really obvious since I’m very new to all this and most of the terminology sounds like Latin to me (progressing from the shiny.io server for the first time), but would really appreciate any pointers!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hello, @mtoepp

Can you please access your server/droplet and open the ssh config file, located in:

/etc/ssh/ssh_config

And make sure that the following line is not comment out (set with # at the beginging)

PasswordAuthentication yes

If the line has # at the beginning, please remove it and then restart the ssh service:

sudo service ssh restart

If Password Authentication is set to yes, then you should be able to connect using a password.

Let me know how it goes.

  • Thanks ageorgiev, I did as you said. The password authentication line was commented out. I restarted the ssh server but still had the same error.

    In case it matters, all the other options under “Host” are also commented out in that file.

    The instructions seem so simple. there’s not a lot of configuration to be done. I’m pretty sure I have the IP correct (pasted in). The other defaults were the correct ones already (ssh 2, port 22, according to the guide I was following. Under “Connection>Data>"auto-login username” I put “root”.

    • Can you also open:

      /etc/ssh/sshd_config
      

      and see if the PasswordAuthentication is set to yes?

      If not, set it to yes and restart ssh

      Looking forward to your reply

Hey, @mtoepp

I’m glad that you’ve sorted this out! Have a great day! :)

  • In fact im facing the same issue, i remove the # from PasswordAuthentication yes and also restarted the server using sudo service ssh restart command. still im getting the same error as “Putty fatal error: No supported authentication methods available (server sent: public key)”.

    I have reset my root password and renew new password from console. im trying to log in using putty via ip address and port as 22. its throwing same error again and again.

    Is there any problem with username as ‘root’ or existing ssh key?

    I delete existing ssh key as well from setting-security page, try again still the same error.

    • Hi,

      Could you please provide me with the output of the following command:

      grep PasswordAuthentication /etc/ssh/sshd_config

      Also can you copy the log from PuTTY so we can check which authentication types it checks before it fails with the error message that you’ve already posted here?

      Regards,
      Alex