how to set domain name (django, nginx, ubuntu 16.04)

August 2, 2016 8.3k views
Nginx Django

Now I use public ip to visit my site. I have bought a domain name (eviacatalog.net) on GoDaddy. How can I set it up so I visit my site with eviacatalog.net and not public IP?

3 Answers

This question was answered by @aha:

First, add your domain eviacatalog.net in the Networking > Domains settings of DigitalOcean.com cloud control panel. Make sure it is pointing to your droplet IP address.

Next, you will need to change the Nameserver settings for your domain in the GoDaddy control panel.

Login to GoDaddy, click on your domain, go to the Manage > Nameservers section, select “Custom Nameservers” and add ns1.digitalocean.com, ns2.digitalocean.com, and ns3.digitalocean.com to the nameserver fields.

For more details see this tutorial - https://www.digitalocean.com/community/tutorials/how-to-point-to-digitalocean-nameservers-from-common-domain-registrars#registrar-godaddy

View the original comment

by Josh Barnett
by Kathleen Juell
DNS is the naming system that is used to bind a domain name to a web server. In this guide, we will change the nameservers for a domain that we have registered and point it to a DigitalOcean Droplet.

thank you! Now open my site but address change from eviacatalog.net to public IP when load.
How I fix that?

  • @ditsikts hmmm - when you open up a terminal and ping eviacatalog.net it still points to a GoDaddy IP Address. It looks like either:

    A) You didn’t actually change the nameservers, but just told GoDaddy to redirect to your IP address or…

    B) The DNS Nameserver change hasn’t actually completed yet (sometimes it takes a while to change)

    Are you sure you changed the nameservers to point to ns1.digitalocea.com etc in GoDaddy control panel?

    • i had redirect but when I add nameservers, option for remove redirect not anymore there, has a lot less options.
      I add nameservers but old nameservers didnt removed, doesnt seems to have option to remove
      update: I check it out now and default nameservers removed and works fine.

I have added my domain name to the Networking > Domains settings and i have changed the Nameserver settings to ns1.digitalocean.com, ns2.digitalocean.com, ns3.digitalocean.com. But when i visit the website via the domain it shows me.

Welcome to nginx!
If you see this page, the nginx web server is successfully installed and working. Further configuration is required.

For online documentation and support please refer to nginx.org.
Commercial support is available at nginx.com.

Thank you for using nginx.
Have another answer? Share your knowledge.