Question

How to update php.ini on a digitalocean app

I’ve deployed a PHP app on digitalocean app and I need to increase the post file size and upload the max file size limit. but I can’t access the php.ini or create a working .htaccess file. Will really appreciate your help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey @sergiowilliomes ,

The easiest way to edit the php.ini settings is to add a .user.ini file to your codebase with the following lines in it. These lines will set the values for post_max_size and upload_max_filesize explicitly:

post_max_size=20M
upload_max_filesize=5M

Alternatively, you could update your run command to be prefixed with the below command:

echo 'post_max_size=20M' >> .user.ini && echo 'upload_max_filesize=5M' >> .user.ini && heroku-php-apache2

Regards,

Dikshith

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I tried .user.ini I also tried to in .htaccess files

php_value memory_limit 30M php_value post_max_size 100M php_value upload_max_filesize 30M

Also didn’t work.

Hello, To find out where the php.ini file is located, use the following command:

  1. php -i | grep php.ini

In the end, we’ll have:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Run the file and adjust the default settings to the size of the largest file you want to upload. By default it is set to :

post_max_size = 8M
upload_max_filesize = 2M
 

You can change the following lines above to:

/etc/php/7.2/cli/php.ini

post_max_size = 30M
upload_max_filesize = 30M

Don’t forget to restart after saving:

  1. service php7.0-fpm restart

Replace with your appropriate PHP version