How to upload file to DO spaces with multiple spaces in filename?

Context I use ‘aws-sdk-s3’ ruby gem to upload files to DO spaces.

Issue When uploading file with multiple spaces in sequence in file name, error returned:

Aws::S3::Errors::SignatureDoesNotMatch (Aws::S3::Errors::SignatureDoesNotMatch)

How can I fix this? Is it DO spaces specific error?

How to reproduce?

require "aws-sdk-s3"
require "content_disposition"

resource =
  access_key_id: "...",
  secret_access_key: "...",
  endpoint: "...",
  region: "...",

bucket = resource.bucket("...")
object = bucket.object("...")

filename = "multiple      spaces.txt"

  body:                "content",
  content_disposition: ContentDisposition.inline(filename),

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.


I tried to reproduce the error you reported but a file was successfully uploaded in my case. I also did another test using s3cmd package on CentOS 7. It worked perfectly well. It is not DO Spaces specific error then.

Here is the configuration I used for reproducing the error.

Droplet - standard Ubuntu image, fully upgraded

cat /etc/os-release
VERSION="20.04.1 LTS (Focal Fossa)"
PRETTY_NAME="Ubuntu 20.04.1 LTS"
ruby -v
ruby 2.7.0p0 (2019-12-25 revision 647ee6f091) [x86_64-linux-gnu]
gem -v
gem info aws-sdk-s3
aws-sdk-s3 (1.87.0)
    Author: Amazon Web Services
    License: Apache-2.0
    Installed at: /var/lib/gems/2.7.0

    AWS SDK for Ruby - Amazon S3
gem info content_disposition
content_disposition (1.0.0)
    Author: Jonathan Rochkind
    License: MIT
    Installed at: /var/lib/gems/2.7.0

    Ruby gem to create HTTP Content-Disposition headers with proper
    escaping/encoding of filenames

My script was just a copy of yours:

require "aws-sdk-s3"
require "content_disposition"

resource =
  access_key_id: "my_access_key",
  secret_access_key: "my_secret_key",
  endpoint: "",
  region: "ams3",

bucket = resource.bucket("my_bucket")
object = bucket.object("multiple      spaces.txt")

filename = "multiple      spaces.txt"

  body:                "content",
  content_disposition: ContentDisposition.inline(filename),

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

card icon
Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Sign up
card icon
Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We’d like to help.

Learn more
card icon
Become a contributor

You get paid; we donate to tech nonprofits.

Learn more
Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow – whether you’re running one virtual machine or ten thousand.

Learn more ->
DigitalOcean Cloud Control Panel
Get started for free

Enter your email to get $200 in credit for your first 60 days with DigitalOcean.

New accounts only. By submitting your email you agree to our Privacy Policy.

© 2023 DigitalOcean, LLC.