I understand that the root user doesn’t have a password, and that, for security reasons, direct root access isn’t available via SSH. That said, there are some instances, such as viewing the contents of directories created with sudo, where you need su, otherwise the prompt isn’t returned to the right user.

Unfortunately, sudo su only results in Su: sorry.

How do I run the su command in FreeBSD 11?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Try using toor account, like:

sudo su - toor

Iirc the shell login for root is disabled. One you login as toor you can change this to enable shell for root.

  • Out of curiosity, how is this any more / less secure than just allowing root to access the shell?

    • IMO it does not enhance security, other than adding some more jumps.
      At best it could avoid accidental execution of a script as root.

      Perhaps someone from DO could shed some light on this.

Submit an Answer