Incorrect characters in console from my key press. How can I fix?

March 10, 2017 5.5k views
DigitalOcean Ubuntu 16.04

I press “a”, and it shows “^[a”. I press “e” and it shows “^[e”.

https://www.digitalocean.com/community/questions/displaying-invalid-character-in-digitalocean-console

The above issue seemed similar, but the solution didn’t work.

8 comments
  • It looks like the console thinks it’s getting the glyph character, which can’t be shown, so it’s replace with ^[ in front of the character you actually wanted to send.
    Are you using the web console or SSH console like Terminal/PuTTY?

  • @hansen - That would be the web console

  • @janiel Same thing happens in different browsers? Are you using the same language on your OS, browser and keyboard?

  • @hansen - Yep, same thing in ms Edge. Same language across everything, (as in using english).

  • @janiel Does it also happens at login, meaning you cannot login, since you cannot write the username/password correctly? Is it a new droplet?

  • Show 3 more comments
7 Answers

Rebooting the server from the web interface (Power option - and the Power Cycle button) appears to have fixed it.

everything I use the pipe key | it turns into >. Anyone else experiencing this? You can imagine how frustrating it is especially how small the DO window is.

Getting exactly as tannerchung above. Pipe | turns into > makes things difficult.

I had the same issue. Really annoying.

I assure you they do not care. Googling the issue verifies this with the hundreds of people that have never received a straight answer over many years now. Do yourself a favor and ditch DigitalOcean. We did and could not be happier!

Have another answer? Share your knowledge.