iptables not blocking ports

January 25, 2017 251 views
Networking Debian

For some reason, iptables isn't blocking ports on a droplet, when the exact same rules work fine on a VirtualBox VM. The output from iptables -S is:

root@public:~# iptables -S
-P INPUT ACCEPT
-P FORWARD ACCEPT
-P OUTPUT ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT
-A INPUT -j DROP

This is modelled exactly on the tutorial at https://www.digitalocean.com/community/tutorials/how-to-set-up-a-firewall-using-iptables-on-ubuntu-14-04, with a small change to the conntrack line due to Ansible's iptables module kind of doing that whether I liked it or not.

But that's not a helpful explanation, since the behaviour of the exact same rule set on Debian 8 is so very different.

Any ideas why this doesn't block on a droplet, i.e., even with these iptables in place, a telnet command to port 554 will connect.

1 Answer

@stuart250691

I've ran in to cases where not setting a default policy results in some connections being allowed.

When I setup iptables or ufw, I always set the default policy to deny that way it's the first rule in my set. That basically says deny everything except what I explicitly allow.

With iptables you can do this by running:

sudo iptables -P INPUT DROP

Though you'd need to remove that last rule in your set first (i.e. -A INPUT -j DROP).

With ufw, it'd be:

sudo ufw default deny

I tend to prefer ufw over directly using iptables as the commands and arguments are a little more straight-forward than they are with iptables (and it's available on both Ubuntu and Debian).

For example, allowing connections on ports 22, 80, and 443, with ufw, is achieved using:

sudo ufw allow 22/tcp \
&& sudo ufw allow 80/tcp \
&& sudo ufw allow 443/tcp

or by setting the default policy first:

sudo ufw default deny \
&& sudo ufw allow 22/tcp \
&& sudo ufw allow 80/tcp \
&& sudo ufw allow 443/tcp

My main reason for using ufw, other than the fact that it's faster to set rules, is the fact that the rules are not ephemeral as they are with iptables (unless you install another package to make them stick).

So when the web server is restarted, ufw will maintain my rules, whereas without another package, iptables will not.

Have another answer? Share your knowledge.