Question

Issue accesing droplet trough domain name (Could not resolve host)

So yesterday I set up a domain for my droplet. First changed the NS on my registrar to digital ocean ones and added the A record to point to the droplet ip from the domain control panel at Digital Ocean. So far so good yesterday the domain was working.

Today when I try to use the domain to ssh/ping/curl the droplet I get an error resolving the host (‘Temporary failure in name resolution’ and (6) using curl)

I tried dig madamove.com @ns1.digitalocean.com to check the domain trough digital ocean ns and the A record is showing the correct ip

; <<>> DiG 9.16.1-Ubuntu <<>> madamove.com @ns1.digitalocean.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 39568
;; flags: qr aa rd; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; WARNING: recursion requested but not available

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 1232
;; QUESTION SECTION:
;madamove.com.			IN	A

;; ANSWER SECTION:
madamove.com.		2307	IN	A	164.92.90.56

;; Query time: 151 msec
;; SERVER: 173.245.58.51#53(173.245.58.51)
;; WHEN: jue may 05 17:49:29 -03 2022
;; MSG SIZE  rcvd: 57

I also tried running an analysis on DNS CHECKER and got 6 DNS that are not resolving the ip.

I understand that DNS resolving can take a while but what bugs my mind is that yesterdar it was working fine even with some dns server not resolving the ip yet.

It could be another issue? Is there something I can do to futher troubleshoot it? Anything can be helpful.

Thanks in advance!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello,

I’ve noticed that the site is already working as expected, so note that it could usually take up to 24/48 hours for the DNS cache to clear over the Globe before you could see the new DNS records.

As the dig madamove.com @ns1.digitalocean.com command returns the correct server IP, this means that you’ve setup the DNS on the DigitalOcean side correctly.

Best,

Bobby