Missing Kernel; formerly a droplet running Ubuntu 12.04

So I have a small droplet which I have been running for years. It’s a LAMP stack on Ubuntu 12.04. It was rebooted due to the spectre/meltdown issue. Anyways, it wasn’t responding and when I checked the droplet through the access console I see that the Digital Ocean Droplet Recovery System is up. I then powered down my server, created a snapshot, and then created a new droplet from the snapshot in order to troubleshoot. With the new droplet setup I have tried going through the recovery system.

  1. I tried first to follow this: The top response goes through a process of selecting the grubloader, going to shell and rebooting. Didn’t seem to do anything.
  2. Next I selected option 6 (Install a Digital Ocean provided Ubuntu 16.04 LTS Kernel). Again nothing happened.
  3. Filesystem check seems to pass
  4. Install/Update kernel on disk does nothing.

Not sure what else to try here.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

So after 30 hours with no help from the DO support I was able to bring back the server back using this method:

  1. Shut down your droplet
  2. Go to the “Kernel” tab and choose the first 12.04 kernel
  3. The kernel will install itself. Now while still offline, choose the “Digitalocean Grubloader v0.2” kernel. So we install first the 12.04 kernel and then switch to the Grubloader v.02, both when the droplet is offline without bringing it back between the installs.
  4. Switch the droplet on
  5. Open the console and type your regular root user and password.

That’s it.

And by the way, digitalocean support sucks. go to hell.

we are already using GrubLoader v0.2 kernell but droplet is down please help

we are having the same problem. DO team, please help

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel