MySQL drops out every few days?

  • Posted September 26, 2012

So I have followed the tutorial to Install Wordpress, Nginx, PHP, and Varnish on Ubuntu 12.04. The process was smooth and easily installed, so no problems there.

The issue is every few days the MySQL connect drops out and when I run the command: $ sudo service mysql start

I get a the following message: $ start: Job failed to start

The other issues is when it first happened, I looked into setting up a script to run in cron every 5 minutes.

ps auxw | grep mysql | grep -v grep > /dev/null
if [ $? != 0 ]
    sudo service mysql start > /dev/null

Then added this to $ cron -e

*/5 * * * * ~/

But that is not working either, any thoughts or help would be greatly appreciated.


@talaviram MySQL is most likely crashing because it’s running out of memory. You can add swap to your droplet which should help with that:

If MySQL still crashes with a swapfile, you might have to upgrade your droplet to a plan with more RAM.

same here :) fails after a few days providing the “Error establishing a database connection”

I am getting the same problem! My Server Mysql stop working few times a day

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Swap fixed my issues

I had same problem, setting up the swap fixed it for me.


Setting up the swap fixed it for me.

Thanks :) And good to know that search is in the pipeline.

Here are the links to the articles on how to add Swap in both Ubuntu and CentOS <br> <br> <br> <br> <br> <br>Thanks for the suggestion on search for the community, it’s already in the works along with auto-search for users when you open up a ticket which will display articles and forum entries which may have info on how to solve an issue. <br>

Sorry for the late reply. It seems to be working after a hard reboot. <br> <br>Silvio - Thanks for the advice but unfortunately the logs where empty. <br> <br>Raiyu - The Community section REALLY needs a Search function, it becomes to time consuming to navigate and find answers. Can you please provide the link to the add swap article?

I have the same problem, i tryied to resize the VPS from 500mb to 1000mb, but MySQL refuses to start…

Your virtual server is most likely running out of resources you can resize to a larger server or add swap. <br> <br>We added articles on how to add swap to the community section.

Hey, <br>Try to start it again and then check your logs: <br> <br>tail /var/log/mysql.err <br>tail /var/log/mysql.log <br>dmesg | grep mysql <br> <br>It should say what’s wrong, and why it’s not starting :)