Question

Next.js Static Site Requires .html extension in URL for Dynamic Routes

Hi,

I haven’t quite figured out why this is happening (and therefore don’t have a solution yet), but I’ve noticed that if I have /pages/[...slug].js to handle all pages including sub-directory style pages (eg, site.com/about and site.com/locations/new-york), the sub-directory pages only work if .html is appended when deploying to DigitalOcean App Platform.

For example: site.com/about works, but site.com/locations/new-york gives a 404 page. However site.com/locations/new-york.html does work (but isn’t desired behaviour).

It does work correctly locally (site.com/locations/new-york loads) by the way.

If I figure out what’s going on I’ll submit a PR :)

This is cross-posted from this GitHub issue by joneslloyd


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

It appears that this is because the generated files are in the form locations/new-york.html and so the .html extension is required for the CDN to locate the files. Fortunately there’s a configurable Next.js setting that turns these generated files into directories like locations/new-york/index.html which will allow you to use site.com/locations/new-york to access them. To enable this option, add the following to next.config.js:

module.exports = {
  trailingSlash: true,
}

(documentation reference)

I’ve tested this and you can see an example in this repo: https://github.com/kamaln7/nextjs-static-index.html-example