Question

"Nginx welcome to nginx" displays www. prefix; works fine without.

I set up Lets encrypt using Certbot, everything works fine when I view my website via “website.com”, however when I use “www.website.com” I get a welcome to nginx landing page.

I’ve attempted to fix this by following a similar question posted on the community: [https://www.digitalocean.com/community/questions/set-up-django-nginx-and-ubuntu-18-04-welcome-to-nginx-landing-page-displays-when-www-prefix-is-loaded-with-domain-works-fine-without] without any success

/etc/nginx/sites-available/default:

server {
        listen 80 default_server;
        listen [::]:80 default_server;

        # SSL configuration
        #
        # listen 443 ssl default_server;
        # listen [::]:443 ssl default_server;
        #
        # Note: You should disable gzip for SSL traffic.
        # See: https://bugs.debian.org/773332
        #
        # Read up on ssl_ciphers to ensure a secure configuration.
        # See: https://bugs.debian.org/765782
        #
        # Self signed certs generated by the ssl-cert package
        # Don't use them in a production server!
        #
        # include snippets/snakeoil.conf;

        root /var/www/html;

        # Add index.php to the list if you are using PHP
        index index.html index.htm index.nginx-debian.html;

        server_name _;

        location / {
                # First attempt to serve request as file, then
                # as directory, then fall back to displaying a 404.
                try_files $uri $uri/ =404;
        }

        # pass PHP scripts to FastCGI server
        #
        #location ~ \.php$ {
        #       include snippets/fastcgi-php.conf;
        #
        #       # With php-fpm (or other unix sockets):
        #       fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
        #       # With php-cgi (or other tcp sockets):
        #       fastcgi_pass 127.0.0.1:9000;
        #}

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #       deny all;
        #}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#       listen 80;
#       listen [::]:80;
#
#       server_name example.com;
#
#       root /var/www/example.com;
#       index index.html;
#
#       location / {
#               try_files $uri $uri/ =404;
#       }
#}

/etc/nginx/sites-available/website:

server {
    server_name website.com www.website.com;

    location = /favicon.ico { access_log off; log_not_found off; }
    location /static/ {
        root /home/…/website;
    }

    location / {
        include proxy_params;
        proxy_pass http://unix:/run/gunicorn.sock;
    }

    listen 443 ssl; # managed by Certbot
    ssl_certificate /etc/letsencrypt/live/website.com/fullchain.pem; # managed by Certbot
    ssl_certificate_key /etc/letsencrypt/live/website.com/privkey.pem; # managed by Certbot
    include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
    ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

}
server {
    if ($host = www.website.com) {
        return 301 https://$host$request_uri;
    } # managed by Certbot

    if ($host = website.com) {
        return 301 https://$host$request_uri;
    } # managed by Certbot

    listen 80;
    server_name server_name website.com www.website.com;
    return 404; # managed by Certbot


}

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there @mrvd,

Your Nginx configuration looks all correct. What I could suggest is checking if your www version has a CNAME DNS record pointing to your main domain.

You can use this DNS tool to check that here:

https://www.digitalocean.com/community/tools/dns

Let me know how it goes! Regards, Bobby

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Update On visiting my website with the ‘www’ prefix it redirect to https://www.website.com with the error: “This site can’t be reached… unexpectedly closed the connection.”