online 4-5 people but cupu 100%.The site works hard. I did what I did. People are nervous.site freezes.

July 24, 2019 244 views
DigitalOcean

Hi, I'm using your service.But I am very worried.I'm using 2gb ram and 1cupu.Before each process was good, but now it is the same number of users but only the cupu is up to 100%.because I trusted you and posted this site.Now what I do is the site works very hard.online 4-5 people but cupu 100%.The site works hard. I did what I did. People are nervous.site freezes.

6 comments
6 Answers
h2hdestek July 25, 2019
Accepted Answer

this problem exists in another person

Hello,

You get dedicated resources like CPU, RAM and Disk space and it is up to you how you use them.

In your case you need to simply investigate the problem, so what you could do is:

  • Whenever you notice high CPU usage, login to the server and run this command: top
  • Then check the process that is using the most of the CPU and see what is going on with that process and what exactly it is doing.

Maybe you have a faulty plugin that is generating the high CPU usage due to long running PHP processes, or maybe there are a lot of sleeping MySQL queries. You just need to login to the server and check what is going on with the processes in order to get to the root cause.

Feel free to share some of the information here and I'll be happy to advice you on how to troubleshoot the problem.

Regards,
Bobby

  • You do not understand .There is a problem with your monitoring.before the site worked normally.The last 20 days is the problem.The cupu rises without cause.traffic has not increased .online 4-5 people and cupu 99% and after 2minutes cupu 70%,and qucik after cupu 100% why?

    • Hello,

      I don’t work for Digital ocean but I have many many severe with them and they are all working perfectly fine.

      You have dedicated resources to your server and it is up to you how you use those resources. The CPU usage is simply caused by your application and the services that you’ve installed on the server.

      Have you tried logging into the server and checking what is actually causing the CPU load? You need to investigate that it is either something wrong with your code or maybe your site has been compromised.

      Regards,
      Bobby

      • The situation is very bad in my site, but my cup is rising.my programmer has checked all the codes.

        • You need to ask your programmer to login onto the server and check the processes and the running services there.

          I'll try to give you an analogy so you could understand that better:

          • Let's say you buy a BMW car, it would have engine, wheels and etc. - the same is with the DigitalOcean servers - you get CPU, RAM, Disk and etc and how you use that it is up to you
          • Your car would also have fuel, and if your car is running low on fuel this means that you have been driving a lot and you've exhausted all of the fuel - the same is with the CPU, if you have a lot of processes on the server you would be exhausting the CPU
          • If your car is running low on fuel you would go to the gas station and add more - the same is with the CPU on the server, maybe you just need more CPUs but first make sure to login to the server and check what actually is going on
          • Also if other people are saying that their cars are low on fuel, it does not mean that the BMW is a bad car right? The same is with the CPU on your server.

          Hope that this helps you!
          Bobby

I believe in you you can connect timevier

  • Look at me again this message.Check back soon, we're loading new metrics
    While you're waiting, learn how to use these new metrics to monitor your Droplet's health.

    • I can't connect via team viewer, what you need to do is login to your server and check the processes that are running.

      Feel free to send me the output and I can give you some advices.

      Regards,
      Bobby

      • You do not understand me. I want to say that the site worked normally 2 months ago but now the cup is rising too. I want to know why.There has been no change in the code and the number of users has not increased.sudden rising cupu then the cup is falling.In some cases, the cup is 5 minutes 100% site frozen

        • Please read my reply above with the car example it will make things clearer for you.

          Let me know if you have any questions.

          • I told you that there was no change in the code on the site, but now the cup is rising. You do not have to check with the machine sample. But it's another matter. I did not have any load on my site but the cup is rising

          • So your next step would be to login to the server and check your processes, that way you will be able to see which process is using the CPU.

Have another answer? Share your knowledge.