Question

Reposting: im getting "503 Service Temporarily Unavailable nginx" when i do "www." on my website

  • Posted July 20, 2020
  • DNS

im getting “503 Service Temporarily Unavailable nginx” when i do “www.” on my website it is working if i just entered my domain without www. it is working I am using easyengine with wordpress and cloudflare for ssl/dns. I tried changing cname on DO and Cloudfkare same issue also tried using A with ip still the same issue please help

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

hi @bobbyiliev sorry i haven been able to respond to your post i actually found a sulution from easyengine her is the page: https://community.easyengine.io/t/ee-site-create-503-service-temporarily-unavailable/12032/7 thank you again for responding

Hi! I was having the same issue and i found this post through google. I have found a way to make it work but it’s not the correct one. I will give my way and hope someone can help us both fix it haha.

I am running a docker compose file in my raspberry pi to host my domain’s website + let’s encrypt certificates. The docker compose file has the budry/jwilder-nginx-proxy-arm, duch/letsencrypt-nginx-proxy-companion:stable and nginx images (the full compose file is from a spanish youtuber hosted in https://github.com/pablokbs/peladonerd/blob/master/raspi/7/docker-compose.yaml ).

What I did was run the compose, copy the /etc/nginx/conf.d/default.conf from the nginx_proxy container to the pi with the command docker cp containerid:/etc/nginx/conf.d/default.conf .

edit it with vim or nano and add the www.domain.com next to my domain.com in both server_name lines in the file and copy the file back to the container. Then enter into the container with the command docker exec -it containerid /bin/bash

and once inside the container I run the command nginx -s reload

Then i checked the www.domain.com and worked perfectly. The only problem now is that this change isn’t persistent and when I run the docker compose file again, the /etc/nginx/conf.d/default.conf gets rewritten and the www.domain.com isn’t next to the domain.com in the server_name line. Do you think how can i make docker nginx_proxy file not rewrite it? It might be the solution for the both of us hopefully.

Thanks and hope it works with you as well!

This comment has been deleted

This comment has been deleted

Hi there @Xunne,

It sounds like that your Nginx server block does not include your www. version, can you share the content of the config file here?

It is stored at:

/etc/nginx/sites-enabled/yourdomain.conf

If this is the case, you need to edit that file, add the www version of your site to the server_name list and then restart Nginx.

Let me know how it goes. Regards, Bobby