tonyoo
By:
tonyoo

Resizing volume is not available even when the droplet is powered off

October 21, 2017 564 views
Block Storage Ubuntu 16.04

The "Resize volume" menu item is greyed out.

Even if I power off the droplet, it is still greyed out. I remember I did resize this volume a few months ago using these instructions https://www.digitalocean.com/community/tutorials/how-to-increase-the-size-of-a-digitalocean-block-storage-volume. Anything changed?

11 comments
5 Answers

First: Shutdown your droplet! Then, click with right button in "Resize volume" and go to "Inspect element" (in Safari, or equivalent in other browsers)... remove 'class="is-disabled"', and the button changes to "available".. click and choose your new size!

I am also having the same issue, I opened a ticket for the same. Yet to get a working solution from DO support since last 4 days. First I was asked to power off the machine and then try to resize, but that did not work. Then I was told to unmount the volume and resize, that too didn't work. Now I am waiting for DO's solution.

I have received an answer from my Support Ticket. The tutorial needs updating with at least two steps to be done prior to the tutorial's steps.

1) Shutdown the droplet
sudo shutdown -h now

2) Refresh the Droplet page in order to refresh the Volume page, then disconnect the Volume from the Droplet using the pulldown (which will then no longer be grey).

3) Follow the tutorial at:
https://www.digitalocean.com/community/tutorials/how-to-increase-the-size-of-a-digitalocean-block-storage-volume

0) During this process I got a corrupted filesystem – I do not know the fault as it could have been something that I did. But I suggest that you backup your Volume offsite as a first step.

It all went smooth until the lsblk step, when I didn't get a filetype or UUID back from the system. Later, at the e2fsck step I got the following error. I report this here in case it happens to others so we can get a history to the Support team:

sudo e2fsck -f /dev/disk/by-id/scsi-0DOVolumemysfo2volumename-part1
Bad magic number in super-block while trying to open /dev/disk/by-id/scsi-0DOVolumedownloads1-part1
Couldn't find valid filesystem superblock.

Good luck

By attaching a DigitalOcean Block Storage volume to a Droplet, you can easily increase your server's capacity as your requirements change. While it's possible to attach multiple volumes to a single Droplet to expand the available capacity of your server, it's also possible to expand the size of an existing volume. This process involves increasing the size of the volume in your DigitalOcean account, followed by some operations on the server itself to expand any partitions and filesystems.
  • This all smells quite bad.
    So essentially we should do this:

    1. create new volume with bigger size
    2. move everything from old volume to new volume
    3. delete old volume
  • Hi! I got the same error you mentioned above (Bad magic number), I then realised that some of the commands refer to the volume name, and some refer to the partition name, i.e.

    scsi-0DO Volume volume-nyc1-01
    scsi-0DO Volume volume-nyc1-01-part1

    When I followed the tutorial mentioned above again, using the right names everything worked perfectly. Just something to watch out for! :)

I found that I can resize the volume by detaching it from the droplet, then go to the volumes tab and then you will see the resize active.
Before detaching the volume, make sure you unmount it in the droplet to make sure you will not have any data corrupted.

Have another answer? Share your knowledge.