Setting up phpmyadmin with my mysql managed database

i have created a managed mysql database, i have a hosting account and upload the phpmyadmin and set the as follows

/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = '';
$cfg['Servers'][$i]['port'] = '25060';
$cfg['Servers'][$i]['ssl'] = true;
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['AllowNoPassword'] = false;

Then i opened the phpmyadmin and i give the username and password for the defaultdb, but i got the following error.

Cannot log in to the MySQL server mysqli::real_connect(): (HY000/2002): Connection refused

i tried with all ways but i cant login to view my database. my hosting is running on php 7.4, even i tried with php 8.0 but getting the same error. Anybody help please.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @binujohn,

Our below community article can guide you in setting up and connecting to MySQL Managed database via phpMyAdmin with SSL.

I hope this helps!

Regards, Rajkishore


There are a couple of things that I could suggest:

  • Try installing PHPmyAdmin manually so that you could get the latest PHPmyAdmin version which should be compatible with the Managed MySQL cluster:

  • If you’ve secured your managed database, make sure that the IP of the Droplet that you’ve installed is added to the trusted sources:

Let me know how it goes!