newvoids
By:
newvoids

"This site can’t be reached" domain

January 6, 2017 1.9k views
Apache Python DigitalOcean DNS Configuration Management PHP Backups API Security

I've recently opened my host in my browser, but it fails to load. It has worked ever since I opened it, but not today. Here's a picture of what happens:
http://i.imgur.com/WQlpnfY.png

Does anyone know the issue? Like I said, it only started happening today.
By the way, the domain is an IP.

Thanks

2 Answers

@newvoids

We'd really need more information about your setup and what has been done before we'd really be able to help diagnose the issue(s).

You can start by checking your error logs and seeing what's showing up there. Since you're tagging this post with Apache, let's start there:

The following paths are based on standard paths used by Ubuntu's package manager (apt), so if you're not using Ubuntu, they may be a little different.

1). Apache's error.log

tail -50 /var/log/apache2/error.log

2). System Logs

tail -50 /var/log/systemlog

3). PHP Logs

tail -50 /var/log/php*.log

If you can copy those to a Pastbin or screenshot each output, I can see if there's an issue.

Also, if you can run

top

and take a screenshot of that as well.

My initial guess, baring any misconfiguration or configuration issues, Apache may have failed, didn't restart, and now the site is down, which could be remedied by restarting Apache. We'd still need to find the root issue though.

  • I can't access anything. When I try to open the DigitalOcean console, it prompts me with this:
    http://i.imgur.com/vvZsMiw.png
    I've tried my MySQL password but this still doesn't work. Do you know what the password could possibly be?

    • @newvoids

      If you setup an SSH key when deploying the droplet, you'll need to SSH in using either the Terminal app on Mac or an app such as PuTTY on Windows and use said SSH key to login.

      If you didn't provide an SSH key when your droplet was deployed, a password was e-mailed to the address you provided DigitalOcean when your account was setup. That's your root password and the one you'll need to use to login.

      • I've tried to use that, but it doesn't work. That has worked previously when it has asked for the console password, but now it's asking for the PhpMyAdmin password.

        • @newvoids

          That should be the hostname associated with the name of the droplet you created. It's not actually asking for the password to phpMyAdmin.

          For example, if you named your droplet mynewdroplet, then you'd see that in place of phpMyAdmin on the console.

          That said, if you're not sure what the password is, login to the DigitalOcean CP and click on the droplet. Now on the left side there's a menu; click on Access. Now you can click on "Reset Root Password" and have a new password e-mailed to you.

          • The username is "root", correct? I tried resetting my password and it still didn't work with that username.

@newvoids

Did you configure your Droplet or did you use a one-click image?

  • I'm using "Ubuntu PHPMyAdmin on 14.04". The server was working a few days ago, now it's not.
    Also, do you have Skype or Discord so we could chat over that? If not that's fine.

    • @newvoids

      When you setup a one-click image, it sends you a password and then you're prompted to change it. The reset link in the control panel should, however, reset that password for you.

      If the new password does not work, you would need to submit a support ticket (as I don't work for DigitalOcean, I just help here on the forums -- else I'd of already helped).

      Essentially, it looks like Apache is down and needs to be restarted, though there's really a bit more to it than that. The one-click installers help to get you up and running, but there's still quit a bit that you need to do in order to maintain a working web server. That includes checking logs for errors and inconsistencies, setting up the firewall (since it's inactive by default) and locking down unused ports, setting up secure environments, etc.

      The one-click installers are simply a starting point to get you off the ground quickly. They are not, however, a hands-free solution.

Have another answer? Share your knowledge.