Question

Ticket Digital Ocean 9 Days Without Response!!

Posted September 14, 2017 2.1k views
UbuntuEmailDigitalOcean

My server port 587, 465, 25 were blocked by DO. I cannot send outgoing emails. Need to get the block lifted. After I provide related info to support, they seem to ignore me. 9 days without a response. Very frustrating… :(

Ticket No. #578581

Also, I send this to forum to let folks know that, if your email service is not working, and you cannot debug, it is probably because DO blocked the port.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers

Hey there,

I’m really sorry about that wait time. Our Trust & Safety team handles these particular requests, and they are a bit short handed right now. Help is on the way, we’re on the path to resolving that as we speak. In the meantime, I’ll take ownership of this for you and you can expect a reply very soon.

Kind Regards,
Jarland
Platform Support Lead

@jarland isn’t kidding about the Trust & Safety team. I created my account like a month ago, and they have yet to verify me :(

Dears at DigitalOcean,
You have deactivated one of our most important droplets last Thursday. It has very critical, sensitive and irrecoverable data that our clients kept with us thinking it would be safe and secure, we also thought so since we deal with a big world-class provider like yourselves. We believe we did not commit any violation to your terms of service, therefore there is no reason you would interrupt our work which depends mainly and exclusively on your web servers. If you don’t fix this issue we will stop dealing with you again and we are warning the others in the field not to do also. Please give us a rational solution to the trouble you caused us.

Droplet IP: 188.166.87.227

Submit an Answer