Trusted sources not allowing connections from my IP

Posted November 28, 2019 2k views
DigitalOcean Managed Redis

1 Managed Redis Database
2 Droplets
1 Development computer

  • Linux Mint
  • NodeJS
  • ioRedis

When: Trusted Sources are empty (Open for everyone)
And: Using Connection Strings
Then: I can connect successfully from both my computer and the droplets

When: Trusted Sources are added,

  • Both droplets, and “Your current computer’s IP (....)” Then: it’s impossible to connect from my computer

I’m using the same testing script, I just change Trusted Sources and run again and it fails immediately.

What’s my IP gives the same result as the automatically IP in Suggested sources

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Maybe you have a dynamic IP and you need to allow your whole IP rage.

Another thing that you could do is from your terminal run:


That way you will find your exact IP that your outgoing traffic is coming from.

  • @ServerEnthusiast

    Thanks so much! You’re awesome, I spent 3 weeks with Tech Support and the ticket was never resolved.

    This one did the trick:


    Thanks again

  • I ran the curl but it gave me an IPV6 address (digital ocean says it doesn’t support IPV6 for sources) so I re-ran with curl -4 which gave me an IPV4 address. I plugged that in and I still am unable to reach my database (unless I open it up and do not restrict its connections).

    For what it’s worth I use my cell phone’s hotspot a lot when I’m on the road and working and I only have this problem when using my cell phone hotspot (AT&T fwiw).

    The address that gave me IS different than what digital ocean detected as my IP address. perhaps it is constantly changing?

    update: I just re ran the curl command and I get the same address back every time. At least while I’m on the connection.