[Ubuntu 14] init-checkconf fails "ERROR: failed to ask Upstart to check conf file"

I have followed this tutorial:

and got as far as the instructions to run “init-checkconf /etc/init/testjob.conf” and that’s where I’m stuck. It fails (after a few seconds), with the message:

 ERROR: failed to ask Upstart to check conf file

so all I know is that my startup task doesn’t work and I can’t figure out why. The checkconf process has written files to /tmp/ but they’re empty, so not much help there.

When I google for this, I find lots of people saying that installing or launching dbus will help. I have tried this and it’s still the same.


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Try using using sudo init-checkconf /etc/init/testjob.conf. That’s what worked for me.