I am working on a custom docker image to automize the backup process, once the task is done it creates a tar file.

Since it runs in a docker image, I would like to pass configuration on the “put” command instead of running s3cmd –configure.

Probably I am missing something, the command below gives ([SSL: CERTIFICATEVERIFYFAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1123)) error

s3cmd put var/dbBackup/backup.tar.bz2 s3://bucket_name --host=nyc3.digitaloceanspaces.com --access_key=xxx --secret_key=yyy

Thanks.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi there,

As per this answer here, what I could suggest is adding the --no-check-certificate flag.

Let me know how it goes.

Regards,
Bobby

  • it solved the problem thanks.

    in case someone else comes to this page, here is the final version of the command :

    s3cmd put var/tmp/file.zip s3://bucket/subFolder/file.zip --host-bucket=bucket --host=nyc3.digitaloceanspaces.com --no-check-certificate --access_key=XXXX --secret_key=YYYYY
    
    edited by bobbyiliev