Question

Why can my application not use port 8080?

Posted August 31, 2021 91 views
Ubuntu 20.04

I am trying to run an application, but it doesn’t start, returning the following error:
The Tomcat connector configured to listen on port 8080 failed to start. The port may already be in use or the connector may be misconfigured.

I tried using netstat to see what application is using port 8080, but it does not seem that there is any application listening on that port.

I tried changing the port to 8081 and 8082, but was unable to connect with those either.

Finally I used sudo to run the application and now it does start, however I do not want to run the application with root access.

Why can my application not use port 8080 without root access?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

I have found the solution, it didn’t actually have anything to do with the port, the error message sent me looking in the wrong direction.
My application didn’t have access to the keystore file where the ssl key was stored, so I needed to change the permissions on that file. After that my app worked fine.

This answer gave me the right clue, 6th answer on a relevant stackoverflow post. :’)
https://stackoverflow.com/a/56584497/10088785

hi @simonprins,

You need root to start a service. It’s how it works.

If you do wish to start the systemd service without root though, you can use the sudoers file. In the sudoers files you can do something like :

Note: for the example the user and group is called DOquestion
Put code in a custom file here: /etc/sudoers.d/DOquestion
Code:

%DOquestionALL= NOPASSWD: /bin/systemctl start my_app
%DOquestionALL= NOPASSWD: /bin/systemctl stop my_app
%DOquestionALL= NOPASSWD: /bin/systemctl restart my_app

The above should do the trick.

  • Hi,

    I am not starting a service, I am running my own java application directly.
    I do intend to make it into a service, but that doesn’t give the application itself root rights, and in fact I do not want it to have root rights.
    I know that priviliged ports (below port 1024) can only be listened to by a program with root priviliges as explained here:
    https://www.w3.org/Daemon/User/Installation/PrivilegedPorts.html
    It goes on to explain that higher numbered ports such as 8080 should be accessible without root priviliges.

    However in my testing my application keeps giving an error that it can’t listen on port 8080 unless it has root priviliges, which seems weird to me.

    When I start the application as a service it keeps stopping and restarting, since it is running into the same problem.