Question

Xfce on CentOS 6.5 x64

  • Posted on April 9, 2014
  • brettAsked by brett

I am relatively new to this so bear with me. I am trying to install Xfce, but the package doesnt seem to exist in the standard repository.

I have tried adding 3rd party repositories with zero success. I have tried about every possible yum command I can find including the group install. e.g.

yum install xfce

Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile

How do you add repositories to these VPS ? My next task is once xfce is installed to get to the desktop via VNC viewer, installing VNC server seems to work, just cant get the desktop. Gnome is available, but not wanted, looking for something lightweight.

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Xfce is available in the Extra Packages for Enterprise Linux (EPEL) repository: <br> <br>https://fedoraproject.org/wiki/EPEL <br> <br>You can install the package that contains the repository information with: <br> <br> wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm <br> rpm -ivh epel-release-6-8.noarch.rpm <br> <br>You should then be able to install Xfce with: <br> <br> yum groupinstall Xfce <br> <br>Xfce can be launched with the startxfce4 command. <br>

How to install Whisker Menu on CentOS 6.7 ?

@brett <br> <br>If you’re connecting via an SSH tunnel, then the firewall shouldn’t be a problem since you can obviously connect to the droplet via SSH already. There’s an article describing how to get this set up on Ubuntu: <br> <br>https://www.digitalocean.com/community/articles/how-to-setup-vnc-for-ubuntu-12 <br> <br>The main difference is the package installation. The instructions for the TightVNC part should be the same. Let us know if you’re still having issues.