May 7, 2013

Beginner

How To Install Webmin on an Ubuntu Cloud Server

Tagged In: Ubuntu, Miscellaneous

About Webmin


Webmin is a web-based interface for system administration for Unix. Using any modern web browser, you can setup user accounts, Apache, DNS, file sharing, and much more. Webmin removes the need to manually edit Unix configuration files, like /etc/passwd, and lets you manage a system from the console or remotely.

Step One—Root Login


Once you know your IP address and root password, login as the main user, root.
ssh [email protected]

Step Two—Add Webmin to APT repository


Edit the /etc/apt/sources.list file on your system and add the following lines.

Open the file with nano:
nano /etc/apt/sources.list

Press [Page Down] button on the keyboard to reach to the end of file. (or press Left ALt+/)

Then paste these two lines below:
deb http://download.webmin.com/download/repository sarge contrib
deb http://webmin.mirror.somersettechsolutions.co.uk/repository sarge contrib

Save changes with CTRL+O and exit with CTRL+X.

Step Three—Install Webmin’s GPG key


You should also fetch and install Webmin’s GPG key in which the repository is signed and with the commands:
cd /root
wget http://www.webmin.com/jcameron-key.asc
apt-key add jcameron-key.asc

Step Four—Install Webmin


You will now be able to install with the commands:
apt-get update
apt-get install webmin

Step Five—Login to Webmin


Open your browser and go to http://your_droplet_ip:10000/

login

You can now login as root with your root password, or as any user who can use sudo to run commands as root.

account

Share this Tutorial

Vote on Hacker News

Try this tutorial on an SSD cloud server.

Includes 512MB RAM, 20GB SSD Disk, and 1TB Transfer for $5/mo! Learn more

Create an account or login:

29 Comments

Write Tutorial
  • Gravatar Neil Sweeney 11 months

    Might be worth mentioning that if you created a root user using a SSH key and thus don't have a password then SSH ing and run the following command sudo passwd root Follow the prompts and then you should be able to login to webmin.

  • Gravatar Kamal Nasser 11 months

    @Neil Sweeney: That is correct, thanks! :]

  • Gravatar KiwoT 9 months

    Hello, I am really a newbie on linux so here is my question: I am using ubuntu 13.04 since I need php 5.4.x And webadmin would make alot of things easier since im bad at linux. So, do I need to install LAMP then install webadmin, or should I just install webadmin right away on my new vps?

  • Gravatar KiwoT 9 months

    also, does that tutorial work on ubuntu 13?

  • Gravatar Kamal Nasser 9 months

    I believe webmin installs Apache for you. I don't know if it can be installed on an Ubuntu 13.04, but you can try it and if it doesn't work, you can rebuild your droplet from a 12.04 image.

  • Gravatar KiwoT 9 months

    Thank you. It works on 13.04 tested yesterday :) But I have changed to 12.04 since its LTS, so just made a lamp install and upgraded to php 5.4 using ppa:ondrej/php5-oldstable. Anyways do you think I should clear my install, and install webmin right away then try to upgrade the php version using ondrej? It worked fine yesterday on 13.04 when I first installed lamp then webmin, still maybe thats not the right way to do it. Thanks

  • Gravatar Kamal Nasser 9 months

    @kevin_thulin: If it's working fine, I don't think you need to redo it again from scratch. Keep it this way for a while and see how it goes.

  • Gravatar garnet 6 months

    If im using digitalocean's lamp stack, what's my default user/pass for sql?

  • Gravatar Kamal Nasser 6 months

    @garnet: root:password, you should change it immediately once you log in (read the MOTD when you log in via SSH or run cat /etc/motd.tail

  • Gravatar shortcut.bolivia 5 months

    Small note: I had to login using https instead of http. Seems to be working fine, except for that little turnaround I had to do in the tutorial.

  • Gravatar me 5 months

    Hi, I get the following error when trying to install webmin: E: unable to locate package webmin Any ideas?

  • Gravatar me 5 months

    Hi, I get the following error when trying to install webmin: E: unable to locate package webmin Any ideas?

  • Gravatar me 5 months

    Hi, I get the following error when trying to install webmin: E: unable to locate package webmin Any ideas?

  • Gravatar Kamal Nasser 5 months

    @me: Did you run

    sudo apt-get update
    ?

  • Gravatar beniliem 5 months

    I already installed Apache & PHP, is it safe to install Webmin? I'm using Ubuntu 12.04 x32 for my Droplet. Thanks.

  • Gravatar Pablo of vDevices.com 5 months

    Suggestion: "You can now login with your root account." should be changed to

    You can now login as root with your root password, or as any user who can use sudo to run commands as root.

  • Gravatar service 5 months

    After install of webmin, can i upgrade / scale my droplet tomorrow without worrying about re-installing it or anything like that?

  • Gravatar Pablo of vDevices.com 5 months

    @me: Did you complete Step Two? I just ran through the tutorial, from start-to-finish, and was able to successfully deploy Webmin.

  • Gravatar Kamal Nasser 5 months

    @Pablo: Thanks, updated. :]

  • Gravatar Kamal Nasser 5 months

    @service: Yes, you can resize your droplet anytime you want without losing your data.

  • Gravatar spencerhill 4 months

    I'm receiving this error as well: E: Unable to locate package webmin On a clean WordPress Droplet.

  • Gravatar spencerhill 4 months

    Ah, the issue for me was a typo: "source" instead of "sources" in step two.

  • Gravatar lachlan.j.healey 4 months

    Tutorial worked great, but I was wondering how I can fix the "Identity not verified" security issue.

  • Gravatar Kamal Nasser 4 months

    @lachlan.j.healey: What do you mean by the "Identity not verified" security issue?

  • Gravatar Kurt Flint 3 months

    Just to help out here, Webmin uses its own server, so no worries about what sort of stack you have installed or upgrading your existing stack. Webmin is a perl app. Might I politely suggest that if you didn't already know that at minimum, you are not prepared enough to install and secure this (or any package you know that little about). At least look something up on Google or even Wikipedia before installing on a server. Know the security histories. See if something is _actively_ maintained and not a black hat's delight. Remember, this is the real world, and apps like Webmin have been known to be security holes of the first order. Gentleman with the MySql question about how your unsecured root login works: stop installing anything and get a book and an experienced friend and jump on those basics before your machine has a rootkit ok? GUIs are not intended to make it so you have to know less about what is under them *nix world like they are for Windows and the Mac. If anything you need to know more to avoid doing things that are insecure. My 2 cents, Kurt

  • Gravatar techaddict009 3 months

    I got https error. How to deal with it?

  • Gravatar Kamal Nasser 3 months

    @techaddict009: That's fine, it's because the cert is self-signed and not signed by a trusted CA.

  • Gravatar christiani.silvia about 1 month

    thanks :) DO is the best

  • Gravatar germanab7 17 days

    I cant access anything. Its like I dont have internet, and can't access ssh, or my webpage or email If I change to another ISP (differente public ip) I can access OK I haved flushed iptables by csf, and nothing I have searched a lot and cant find anything. Thanks

Leave a Comment

Create an account or login:
Ajax-loader