Question

How to install Yarn on DigitalOcean's App

I have deployed an application using DigitalOcean’s App service. The way I understood the service is that they will package everything you need for your application to run.

However, when I tried to compile the assets on the console they provide I get the following error:

Yarn executable was not detected in the system. Download Yarn at https://yarnpkg.com/en/docs/install

I tried to install it via the console but it would not work. I have installed yarn on the droplet where the application resides but that did not have any affect.

How can I resolve this issue?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

👋 @ChellGouda

Currently, yarn is only included if the webpacker gem is included in the project Gemfile. We are looking into add more methods to detect when yarn should be included!

Happy Hacking!

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

My rails app is currently using cssbundling-rails and not webpacker. Could the detection script be modified to also include that?

Or better yet – just look for the presence of yarn.lock in the root of the app?