Question

How to switch from password to ssh key authentication?

Posted June 7, 2020 151 views
CentOSCentOS 8

I created a droplet with root password. Is it possible to change to ssh key authentication without destroying and recreating the droplet?
I have already done considerable work on hte droplet and hate to start over again.
Thanks

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @cpeters5,

There are 3 things you would need to do in order to switch to a using an ssh key rather than a password.

The first step would be to generate an ssh key. On your machine, in the terminal run the following command

 ssh-keygen -t rsa -b 4096 -C "your_email@example.com"

When you’re prompted to “Enter a file in which to save the key,” press Enter. This accepts the default file location.

Now you should have an SSH key located in

~/.ssh/id_rsa.pub

Copy the contents of the file.

The second step is to add the key to your Droplet. To do that, SSH to it

ssh root@YOurDropletIp

Once you are in open the following file and paste what you’ve copied for your ssh key in it

nano ~/.ssh/authorized_keys

Inside the file on the last line, paste it. Disclaimer, it should all be on one line!

Now you’ve added your SSH key.

The third step is to enable key authentication on the droplet. While you are on the droplet open the following file

nano /etc/ssh/sshd_config

Inside the file, search for a directive called PubkeyAuthentication. This may be commented out. Uncomment the line and set the value to “yes”. This will enable your ability to log in through SSH using ssh keys:

PubkeyAuthentication yes

Save and close the file when you are finished. To actually implement the changes we just made, you must restart the service.

service ssh restart

That’s it you now can ssh with a key rather than a password.

Regards,
KDSys

  • Thank you KDSys. Works like a charm. I have been searchinf for answers and tried them all without any success. The thing I missed was to turn on PubkeyAuthentication!

Submit an Answer