Question

I cannot upload files to Ubuntu by php

Posted April 22, 2021 514 views
ApachePHPUbuntu 20.04

I am using the digitalocean droplet, ubuntu 20.04.
I am using the php (Codeigniter) for my web application.
When I tried to upload files, the uploading was not successful.
After I change the upload directory permission to 777, it worked.
But I do not want to use 777 because it is risky in terms of security.
Maybe 755 or 775 are fine. But the php cannot upload files to the 755/775 directories.

Do I need to change the default-ssl.conf / 000-default.conf ? or apache2.conf or php.ini ?
How can make the php code run with the root permission ?

It’d be great if you could advise me.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi there @actionismostimportant,

What you could do is to set the owner and the group of the files to the Apache user. That way you will be able to use 755 as the permissions.

By default the Apache user is www-data if you have changed that you can find the Apache user with the following command:

ps aux | grep -i apache

You would need to look at the first column.

Then to change the owner of your upload directory you can use the chown command:

chown www-data:www-data /path/to/your/upload_dir

Hope that this helps!
Regards,
Bobby

  • Thank you so much for your advice ! That worked.

    I run this command. Then I saw there are 2 users. root and www-data. *First column was root, then 2nd onwards were www-data.

    ps aux | grep -i apache
    

    Then I run this.

    chown -hR www-data:www-data /path/to/my/upload_dir
    
    

    I think I needed “-hR” in order to apply the changes to all the directories/files under the directory.