I'm having trouble understanding how to view my docker container via my droplet IP

I’m simply trying to view my app in a browser via the IP address. I’m new to docker. I’ve spent a fair amount of time today trying to figure this out, but need a little help.

I have a docker container locally running a silverstripe app. Ive set this container up on a droplet using the marketplace/docker image. The app seems to all be setup and running as it should.

I have a docker-compose.yml file - the top looks like this:

version: "3.5"
      context: .docker/www
      dockerfile: Dockerfile
    container_name: myname-www
      - "${WWW_HTTP_PORT}:80"
      - "${WWW_HTTPS_PORT}:443"

this is sitting in the project folder: /var/myname

and in an .env file I have these lines:

# Docker Configuration

I’ve got those port numbers from this install page:

I have setup a firewall in my control panel: HTTP TCP 80 HTTPS TCP 443

but I’m still getting a 404 - nginx/1.10.3 (Ubuntu) page.

Any help would be appreciated. thanks.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

DigitalOcean Employee
DigitalOcean Employee badge
April 30, 2019
Accepted Answer


It looks like you might be trying to expose the docker container to the docker daemon ports. You also may have an existing install of Nginx that you have running. If you intend to expose your app directly to web ports, you may also want to disable/remove the Nginx installation that is running.

Make sure that your ports are mapping to the ones that you want. So if the internal port were 81 and you want the external port to be 80, it’s “80:81” when spinning up the container. In your case it’s probably just “80:80” but I wanted to show that it’s “exposed:source” when mapping.

To give you some insight into my world and how I expose containers, I have a copy of searx running with this command:

docker run -d -p 82:8888 wonderfall/searx

Then I have Caddy running a reverse proxy (maybe you intend to use Nginx) with this config: {
        proxy / {

You can see it exposed at Hopefully that helps :)


Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel