I need Help error Ubuntu 18.04 CyberPanel

January 9, 2019 973 views
Linux Commands Ubuntu 18.04

I have an error updating ubuntu which shows me the following

Ign:1 http://mirrors.digitalocean.com/debian bionic InRelease
Ign:2 http://mirrors.digitalocean.com/debian bionic-updates InRelease
Ign:3 http://mirrors.digitalocean.com/debian bionic-backports InRelease
Err:4 http://mirrors.digitalocean.com/debian bionic Release
  404  Not Found [IP: 2604:a880:0:1::4 80]
Err:5 http://mirrors.digitalocean.com/debian bionic-updates Release
  404  Not Found [IP: 2604:a880:0:1::4 80]
Err:6 http://mirrors.digitalocean.com/debian bionic-backports Release
  404  Not Found [IP: 2604:a880:0:1::4 80]
Ign:7 http://security.debian.org bionic/updates InRelease
Err:8 http://security.debian.org bionic/updates Release
  404  Not Found [IP: 2a04:4e42:1d::204 80]
Reading package lists… Done
E: The repository 'http://mirrors.digitalocean.com/debian bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://mirrors.digitalocean.com/debian bionic-updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://mirrors.digitalocean.com/debian bionic-backports Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'http://security.debian.org bionic/updates Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

code
2 Answers
jarland MOD January 9, 2019
Accepted Answer

Hey friend,

Somehow your apt configuration has replaced Ubuntu with Debian. Try this:

First back up your sources.list file:
cp /etc/apt/sources.list /etc/apt/sources.list.bak

Then let’s change Debian to Ubuntu:

sed -i 's/debian/ubuntu/g' /etc/apt/sources.list

Then let’s get rid of that last one:

sed -i 's/http:\/\/security.debian.org/#http:\/\/security.debian.org/g' /etc/apt/sources.list

And finally let’s run the update:

apt-get update

Jarland

Have another answer? Share your knowledge.