Invalid permissions on fresh dokku host

Posted July 27, 2016 5.6k views

I just created a new dokku one app intall, and it appears something went wrong with the setup.

I created the droplet, visited the IP and completed the dokku setup process. I added my droplet as a remote for my git project and pushed.

› git remote add dokku
› git push dokku master
fatal: 'hello' does not appear to be a git repository
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

I can ssh into as well as root@. I tried creating an app named hello on my droplet, but I still get the same error. I don’t feel I’ve missed any steps in the dokku setup process explained on both the Digital Ocean guide or the dokku documentation. Am I missing something?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Reading more of the documentation, this article helped me:

I’m not sure why I was able to ssh in, but unable to git push with the same ssh key, but either way passing a fresh copy of my ssh key to the server did the trick:

# from your local machine
# replace with your domain name or the host's IP
# replace root with your server's root user
# USER is the username you use to refer to this particular key
cat ~/.ssh/ | ssh "sudo sshcommand acl-add dokku USER"