Question

OpenLiteSpeed WordPress + Managed Redis. Connection Test: Failed

Hello,

I have created a droplet using the OpenLiteSpeed WordPress 1-Click image. I have also created a Managed Redis DB to use for object cache, however I am unable to connect the bundled LSCache WordPress plugin to the Redis DB.

I add the host, port, user and password and neither the public nor private networks seem to work. All I get from the plugin is Connection Test: Failed.

Any ideas what might be going wrong?

Thank you!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

It looks like redis-cli doesn’t support SSL, so you need to take a few extra steps:

sudo apt update
sudo apt install redis-tools stunnel4

sudo nano /etc/default/stunnel4

Add the following line:
ENABLED=1


sudo nano /etc/stunnel/stunnel.conf

Add the following lines changing the host and port:
fips = no
setuid = nobody
setgid = nogroup
pid = /redis/pids/stunnel.pid
debug = 7
delay = yes
[redis-cli]
  client = yes
  accept = 127.0.0.1:8000
  connect = REDIS_HOST:REDIS_PORT

sudo mkdir /redis
cd /redis
sudo mkdir pids
sudo chown -R nobody:nogroup pids/
sudo systemctl restart stunnel4

Testing if it worked:

sudo redis-cli -h localhost -p 8000 -a PASSWORD
ping

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

try this script

<?php
 
$redis = new Redis();
//Connecting to Redis
$redis->connect('hostname', port);
$redis->auth('password');
 
if ($redis->ping()) {
        echo "PONGn";
}
 
?>

replace hostname , port and password to your own information

then access it , see if it connects