setting up VPN on Ubuntu 16.04 build-ca error message

Running Ubuntu 16.04 on a HP Pavilion laptop In following your tutorial “How to set Up an OpenVPN server on Ububtu 16.04” I got to step 4 “Build the Certificate Authority” and when I ran the ./build-ca command I got the following output:

Generating a 2048 bit RSA private key …+++ …+++ unable to write ‘random state’ writing new private key to ‘ca.key’

As you can see it is telling me it can not write the random state. I want to know if I can ignore this message and continue or what I might try to fix it.

Any and all help is appreciated.


While I wait for an answer I decided to try to continue. Upon running the ./build-key-server server I go the same message on the last line of the output:

1 out of 1 certificate requests certified, commit? [y/n]y Write out database with 1 new entries Data Base Updated unable to write ‘random state’

Any and all help is appreciated.

sorry I tried to bold the line “unable to write ‘random state’” but it did it to the following line. I am new to this site.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi @raygolost

It’s usually because your .rnd is not owned by the user. You can remove it:

sudo rm ~/.rnd

You can read more here: