Question

Sorry, we couldn't find an app in your repo

I have a Django app running successfully on my local machine. I pushed it to a Github repository and tried to deploy it to Digital Ocean using the new App Platform. I connected the repository successfully but then got an error ‘Sorry, we couldn’t find an app in your repo’.

I tried to read the ‘How To Deploy a Django App on App Platform’, but it is all about how to create a Django app, I don’t really need that.

Are there specific requirements, maybe some special settings, that would help the App Platform to recognize my app?

Subscribe
Share

I’m finding the same thing with Django and Launch App. My github repo has requirements.txt in the root so should work. I even tried forking the DO django example app but same issue (https://github.com/digitalocean/sample-django).


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

👋🏼 @sundraw

For App Platform to detect a Python app, the repo must include at least one of the following files at the root: requirements.txt, Pipfile, or setup.py. We’re working on making that clearer in the error response.

You can refer to the documentation page for more info: https://www.digitalocean.com/docs/app-platform/languages-frameworks/python/#limits

I hope that helps!