I have followed every guide to disable ipv6 and yet after EVERY reboot I am still seeing it enabled. How do I disable it?

net.ipv6.conf.eth0.disable_ipv6 = 0

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Looks like /etc/default/grub.d/50-cloudimg-settings.cfg overrides the GRUB_CMDLINE_LINUX_DEFAULT="console=tty1 console=ttyS0 ipv6.disable=1" line. So set it in that file and then run update-grub.

I put the following in /etc/sysctl.conf:

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
Submit an Answer